Nutanix Resiliency: Invisible Failure (Part I:Introduction and Disk...
.Resiliency is the ability of a server, network, storage system,to recover quickly and continue operating even when there has been an equipment failure, or other disruption.Invisible Infrastructure...
View ArticleFoundation: Then, Now and Beyond
In creating a world class product, the challenge is always to develop something that is flexible,useful and simple. Many times, simplicity is lost at the expense of greater flexibility or flexibility...
View ArticleNCC - The Swiss Army Knife of Nutanix Troubleshooting Tools.
The Swiss Army knife is a pocket size multi-tool which equips you for everyday challenges. NCC equips you with multiple Nutanix troubleshooting tools in one package.NCC provides multiple utilities...
View ArticleNutanix Shadow Clones
Introduction: Nutanix shadow clones were introduced in NOS 3.2 to provide a quicker response for the read-only multi-reader vmdks that are accessed from multiple hosts. From NOS 3.5.5 and 4.0.2...
View ArticleAFAik, with NX-9000, Nutanix brings Webscale to Flash.
Before you begin, I strongly recommend you read these fantastic blogs.goodbye-dual-controller-arrays-hyperconvergence-meets-all-flash/ - @LukasLundell - explains why flash needs webscale...
View Article4.0 Feature: Cluster Health Framework
Nutanix cluster health is designed to detect and analyze Nutanix cluster related failures to bring more customer visibility to the issues by providing cause/impact and resolution. Nutanix cluster...
View ArticleHyper-Converge DELL server into server-SAN with Nutanix
Nutanix has always included software capable of running on generic off-the shelf hardware. (as in above figure, x86 hardware) Even though the software is abstracted to run on any hardware, Nutanix...
View ArticleWhy Nutanix is a web-scale architecture ?
Recently, there has been a lot of buzz surrounding web-scale IT and every vendor claims that they are web-scale IT. So, what qualifies a software or architecture as a web-scale architecture?What...
View ArticleNutanix 4.0 Feature - Protection against Simultaneous Double points of failure
Nutanix provided replication factor/resiliency factor of two from day one. Due to request from customers who wanted to provided higher level of resiliency, Nutanix has RF=3 support from 4.0.Pre 4.0...
View ArticleNutanix 4.0 Feature - Fault Domain Awareness
“A fault domain is a set of hardware components – computers, switches, and more – that share a single point of failure.” Nutanix provides many ways of achieving resiliency and fault tolerance. For the...
View ArticleNutanix support delivers world class support - no surprise!
Omega Management Group recognized 35 companies for “Delivering World-Class Customer Service” in 2013. Nutanix is one of the companies that received the award based on top-notch Net Promoter Score and...
View ArticleDisable video in Nutanix UI login screen
Some of the customers who are in a home office managing the Nutanix cluster in a remote datacenter , the loading of the video ( though cool) might take longer.To disable the video, please append the...
View ArticleEnabling, Monitoring and Disabling Dedup
dedup info:http://nutanix.blogspot.com/2013/08/introducing-nede-nutanix-elastic-dedup.htmlEnabling Dedup1.- it can be done per containerncli ctr edit name=xyz fingerprint-on-write=on- it can be done...
View ArticleNo SAN, No Cry
"No SAN No Cry"No, SAN, no cry;No, SAN , no cry;No, SAN, no cry;No, SAN, no cry.'Cause - 'cause - 'cause I remember when we used to sitIn a dark server room in Trenchtown,Oba - obaserving the bad pWWN...
View Articlevmware: Unidesk VM on NFS taking about a minute to start booting up.
Here we look at traces (NFS) to find few inefficiencies of VMware NFS clientunidesk config: there is Workaround available: (from nutanix/unidesk support)The workaround is to follow these guidelines:1....
View ArticleNutanix DR troubleshooting
This is my scratch pad that I use for DR troubleshooting. Basics: Cerebro Master(CM): - maintains persistent metadata (PDs/VMs/Snapshots), acts on Active PD schedule, replicate snapshots, handshake...
View ArticleNutanix cluster start -Troubleshooting
1. Cluster create -cluster discover-nodes- Network connectivity - all the nodes in same broadcast domain- /etc/nutanix/factory_config.json - has right config - node location, serial number-...
View ArticleWhat node removal process does in the background ?
Note: These two commands should work and has been tested in QA. ncli host start-remove id=X ncli host get-remove-statusncli host remove-finish id=X says that host MARKED_FOR_REMOVAL_BUT_NOT_DETACHABLE...
View ArticleIntroducing NEDE ( Nutanix Elastic Dedup Engine)
Nutanix elastic dedup engine issoftware driven,scalable/distributed/inline data reduction technology for Flash and cache tiersfingerprints on sequential write ,dedup in RAM/Flash on Read.Nutanix...
View ArticleUnable to enable HA on one ESXi host
Problem Description:Host ABCD (x.y.z.150) is unable to start vSphere HA. The current state is "vSphere HA Agent Unreachable". I have tried to start HA twice, but this did not resolve the issue.KBs to...
View Article